Настройка Cisco Wireless LAN Controller и Cisco Lightweight Access Point

Автор cisco
13.01.2010 г.

Вступление

В данной статье мы рассмотрим базовую настройку беспроводной точки доступа Cisco lightweight access point (AP), которая подключена к контроллеру Cisco Wireless LAN (WLC) через свитч Cisco Catalyst.

Требования

Убедитесь в том, что ваша конфигурация соответствует следующим требованиям:

  • Базовые знания в области настройки беспроводных точек доступа Cisco lightweight AP и контроллеров Cisco WLC
  • Базовые знания в области облегчённого протокола беспроводного доступа LWAPP
  • Базовые знания в области настройки внешнего DHCP сервера и/или сервера доменных имён (DNS)
  • Базовые знания в области настройки свитчей Cisco Catalyst

Используемые компоненты

Информация, представленная в данном документе, базируется на следующем оборудовании и ПО:

  • Беспроводные точки доступа Cisco Aironet серии 1232AG
  • Cisco WLC серии 4402 с firmware 5.2.178.0
  • Microsoft Windows Server 2003 Enterprise DHCP server

Данная конфигурация так же может быть использована с другими моделями Cisco WLC и Cisco lightweight AP.

Информация в данном документе была собрана посредством лабораторных работ в тестовой среде.

Все устройства были с заводскими установками.

Прежде чем использовать данные из этой статьи в рабочей сети убедитесь в том, что Вы осознаёте все действия.
Все устройства использовались с настройками по умолчанию. Не забудьте сделать резервную копию конфигураций.

Немного теории

Контроллеры Cisco WLC способны управлять «облегчёнными» беспроводными точками доступа (далее LAP), которые в свою очередь «ищут» контроллер и регистрируются на нём. Это сравнимо с клиентами DHCP, которые посылают широковещательные запросы в поисках сервера DHCP.

Существует несколько методов, которые используют LAP для поиска контроллера Cisco WLC. Более детально о методах регистрации Cisco LAP на контроллерах Cisco WLC вы найдёте по ссылке   Регистрация Cisco Lightweight AP (LAP) Registration на Wireless LAN контроллере (WLC)

В данном документе рассмотрены шаги конфигурации, которые необходимы для регистрации Cisco LAP на контроллерах Cisco WLC и базовые операции по настройке беспроводной сети LWAPP на оборудовании Cisco.

Конфигурация

Для регистрации LAP на контроллере Cisco WLC и для базовых операций над беспроводной сетью LWAPP необходимо выполнить следующие шаги:

  • Иметь сервер DHCP, который будет выдавать в аренду ip адреса для беспроводных точек доступа Cisco (далее AP). Примечание: Опция 43 (DHCP сервера) используется для AP, которые находятся в другой подсети, чем контроллер Cisco WLC.
  • Настроить контроллер Cisco WLC для базовых операций.
  • Настроить свитч Cisco (в нашем случае это Cisco Catalyst) для контроллера Cisco WLC.
  • Настроить свитч Cisco для AP.
  • Зарегистрировать Cisco AP облегчённой версии на контроллере Cisco WLC.

Информация, представленная в данном документе, основана на следующей сетевой диаграмме:

Настройка Cisco Wireless LAN Controller и Cisco Lightweight Access Point
Настройка Cisco Wireless LAN Controller и Cisco Lightweight Access Point

Настраиваем контролер Cisco WLC для базовых операций

Когда контроллер Cisco загружается с заводскими установками, то запускается скрипт в виде мастера настроек, который выполняет действия по начальному конфигурированию. Далее мы рассмотрим процедуру начальной конфигурации контроллера Cisco WLC описывает, как использовать интерфейс командной строки (CLI) для начальной настройки котроллера Cisco.

Примечание: Убедитесь в том, что вы знаете (а самое главное понимаете) как настраивать внешний DHCP сервер и/или сервер DNS.Выполните следующие шаги для начальной настройки контроллера Cisco WLC:Подключите ваш компьютер к контроллеру Cisco WLC при помощи ноль модемного серийного кабеля (DB-9).

Откройте эмулятор терминала и произведите следующие настройки:

  • 9600 Скорость
  • 8 бит данных
  • 1 стоповые биты
  • Нет чётности
  • Отключенное аппаратное управление потоком

Зайдите на командный интерфейс управления (CLI).По умолчанию имя пользователя и пароль для доступа на контроллер Cisco WLC это admin. Если стандартные имя пользователя и пароль не подошли (мы говорим о «чистой» железке с заводскими установками), то выполните команду reset system до загрузки контроллера.

После первого запуска мастера установки введите имя для контроллера Cisco. Имя может содержать до 32 символов ASCII.

На следующем шаге введите имя и пароль для администратора.

Имя пользователя и пароль могут содержать до 24 символов ASCII.

Введите сервис-порт протокола конфигурации IP , либо одно из значений none или DHCP. Введите none если вы не хотите использовать сервис порт или если вы хотите использовать для сервис-порта статический IP адрес.

Если вы введёте none на седьмом шаге, значит, вам будет необходимо ввести статический IP адрес для сервис порта и соответственно маску подсети следующих шагах мастера начальной конфигурации контроллера Cisco WLC. Если у вас нет желания использовать сервис порт введите 0.0.0.0 для IP адреса и маски подсети.

Введите значения для следующих опций:

  • IP адрес интерфейса управленияo
  • Сетевая маска IP адреса для шлюза по умолчанию
  • Опционально – идентификатор VLAN

Вы можете использовать существующий идентификатор VLAN или идентификатор 0 (ноль) для настройки VLAN позднее.

Примечание: Когда интерфейс управления на контроллера настроен как часть «родного VLAN» на switchport (свитча Catalyst), к которому он подключен, контроллер НЕ помечает кадры. to which it connects, the controller should NOT tag the frames.
Поэтому вы должны установить нулевое значение VLAN на контроллере.

  • Введите номер порта для физического сетевого интерфейса (Distribution System).
  • Для WLC можно использовать порты от 1 до 4 для гигабитных портов на передней панели.
  • Введите IP адрес DHCP сервера, который будет выдавать IP адреса клиентам, интерфейсу управления и интерфейса сервис порта, если используется только один интерфейс .
  • Введите тип транспорта LWAPP, один из LAYER2 или LAYER3.

Примечание: Если вы настраиваете контроллер Cisco WLC 4402 при помощи мастера конфигурации и выбираете в качестве транспорта LAYER2 для AP, то мастер конфигурации не будет задавать вопросы касающиеся менеджера AP. Введите IP адрес для виртуального шлюза (Virtual Gateway). Этот IP адрес может быть фиктивным (вымышленным), не использующимся IP адресом, как например IP адрес 1.1.1.1, который в последующем будет использоваться для Layer 3 Security и Mobility интерфейсами управления.

Примечание: Обычно в качестве IP адреса для виртуального шлюза выбирается приватный IP адрес.Введите имя для Cisco WLAN Solution Mobility Group/RF Group.Введите WLAN 1 service set identifier (SSID) или сетевое имя .Данный идентификатор SSID будет использоваться беспроводными точками доступа Cisco в качестве идентификатора по умолчанию при подсоединении их (точек) к контроллеру Cisco WLC.
Разрешите или запретите использование статических IP адресов клиентами.Выберете yes для разрешения клиентам получать их собственный IP адрес. Выберете no для того, чтобы клиенты запрашивали IP адреса у DHCP сервера.

Если вам необходимо настроить RADIUS сервер на контроллере Cisco WLC, выберете yes и введите следующую информацию:

  • IP адрес RADIUS сервера
  • Порт коммуникаций
  • Секретный ключ (shared secret) Если у вас нет необходимости в конфигурировании RADIUS сервера или вы хотите настроить его позже, то выберете no.
  • Введите код страны.
  • Введите команду help чтобы получить список доступных кодов для стран.
  • Включите или выключите поддержку для IEEE 802.11b, IEEE 802.11a и IEEE 802.11g.
  • Включите или выключите radio resource management (RRM) (auto RF).

WLC 4402— Мастер конфигурации
Welcome to the Cisco Wizard Configuration Tool
Use the ‘-‘ character to backup

  • System Name [Cisco_43:eb:22]: c4402
  • Enter Administrative User Name (24 characters max): adminEnter
  • Administrative Password (24 characters max): *****
  • Service Interface
  • IP Address Configuration [none][DHCP]: none
  • Enable Link Aggregation (LAG) [yes][NO]: No
  • Management Interface IP Address: 192.168.60.2
  • Management Interface Netmask: 255.255.255.0
  • Management Interface Default Router: 192.168.60.1
  • Management Interface VLAN Identifier (0 = untagged): 60
  • Management Interface Port Num [1 to 2]: 1
  • Management Interface DHCP Server IP Address: 192.168.60.25
  • AP Transport Mode [layer2][LAYER3]: LAYER3
  • AP Manager Interface IP Address: 192.168.60.3
  • AP-Manager is on Management subnet, using same values
  • AP Manager Interface DHCP Server (192.168.50.3): 192.168.60.25
  • Virtual Gateway IP Address: 1.1.1.1
  • Mobility/RF Group Name: RFgroupnameNetwork Name (SSID): SSID
  • Allow Static IP Addresses [YES][no]: yes
  • Configure a RADIUS Server now? [YES][no]: no
  • Enter Country Code (enter ‘help’ for a list of countries) [US]: US
  • Enable 802.11b Network [YES][no]: yes
  • Enable 802.11a Network [YES][no]: yes
  • Enable 802.11g Network [YES][no]: yes
  • Enable Auto-RF [YES][no]: yes

Примечание: Интерфейс управления на контроллере Cisco WLC является единственным внешним интерфейсом, который можно «пинговать». Поэтому для вас не должно быть неожиданностью то, что вы не можете проверить доступность, используя команду ping, из внешней сети.

Примечание: Вы должны настроить интерфейс управления AP manager для того, чтобы беспроводные точки доступа Cisco могли регистрироваться на контроллере Cisco WLC.

Настройка Cisco Catalyst для контроллера Cisco WLC

В данном примере используется свитч Cisco Catalyst 3750, который использует только один порт. Интерфейс AP-manager и интерфейсы управления «подключены» на VLAN 60. Свитч порт сконфигурирован как IEEE 802.1Q транк (trunk) и только соответствующие VLAN`ы, со второго VLAN по 4 VLAN и 60 VLAN, в данном примере, разрешены на транке. Управляющий и AP-manager VLAN (VLAN 60) «помечены» и не настроены как активный VLAN для транка. Поэтому, в данном примере настраивая интерфейсы на контролере Cisco WLC, мы «ассоциируем» данные интерфейсы с идентификатором VLAN.

Рассмотрим на примере конфигурацию свит порта 802.1Q:
interface GigabitEthernet1/0/1
description Trunk Port to Cisco WLC
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2-4,60
switchport mode trunkno shutdown

Примечание: Когда вы подсоединяете гигагибтный порт WLC, убедитесь в том, что он подключен только к гигабитному порту на свитче Cisco Catalyst. Если вы подсоедините гигабитный Ethernet порт контроллера Cisco WLC к порту FastEthernet свитча, то работать данная связка не будет. Так же примите во внимание то, что в данном примере конфигурации «соседние» порты VLAN`ов на свитче используют 802.1Q транк. Все остальные VLAN «отрезаны». Данная конфигурация не является необходимой, но она одобрена так называемыми «лучшими практиками применения» — best practice. Когда вы «отбросите» не относящиеся к работе контроллера VLAN`ы, то контроллер Cisco WLC будет обрабатывать только необходимые фреймы, что увеличит производительность.

Настройка Cisco Catalyst для беспроводных точек Cisco AP

Ниже представлен пример настройки VLAN интерфейса на Cisco Catalyst 3750:

interface VLAN5
description AP VLAN
ip address 10.5.5.1 255.255.255.0

Несмотря на то, что контроллер Cisco WLCs использует 802.1Q trunk`и, беспроводные точки доступа Cisco lightweight AP не понимают «помеченные» (tagging) VLAN и должны быть подключены только к access порту свитча Cisco Catalyst (который естественно должен быть «соседом» контроллера Cisco WLC)

Ниже представлена конфигурация switch port`а для Cisco Catalyst 3750:

interface GigabitEthernet1/0/22
description Access Port Connection to Cisco Lightweight AP
switchport access vlan 5
switchport mode access
no shutdown

Если вы всё сделали правильно, то ваша инфраструктура теперь готова к присоединению беспроводных точек AP. Беспроводные точки доступа используют различные методы обнаружения контроллеров WLC и выбирают контроллер для присоединения. После того, как контроллер Cisco WLC был обнаружен беспроводными точками они (точки доступа) регистрируются на контроллере.

Проверка
Используйте данный раздел для проверки своей конфигурации. После того, как беспроводные точки доступа Cisco зарегистрировались на контроллре , вы можете посмотреть их на закладке Wireless верхнего меню пользовательского интерфеса контроллера Cisco WLC:

Настройка Cisco Wireless LAN Controller и Cisco Lightweight Access Point
Настройка Cisco Wireless LAN Controller и Cisco Lightweight Access Point

Для того, чтобы убедится в том, зарегистрировались ли беспроводные точки Cisco на контроллере Cisco WLC при помощи командного интерфейса (CLI) вы можете воспользоваться командой show ap summary:

(Cisco Controller) >show ap summary Number of APs……………………………… 1 Global AP User Name………………………… Not ConfiguredGlobal AP Dot1x User Name…………………… Not Configured AP Name Slots AP Model Ethernet MAC Location Port Country Priority—————— —— ——————- —————— —————- —- ——- ——AP001b.d4e3.a81b 2 AIR-LAP1232AG-A-K9 00:1b:d4:e3:a8:1b default location 2 IN 1

Так же вы можете воспользоваться командой show client summary:

(Cisco Controller) >show client summary Number of Clients…………………………..

1 MAC Address AP Name Status WLAN Auth Protocol Port

—————— ————- ————- —- —- ——— —-

00:40:96:a1:45:42 ap:64:a3:a0 Associated 4 Yes 802.11a 1

(Cisco Controller) >

Решение проблем

Используйте данный раздел для разрешения возникших проблем.

Команды Команда debug lwapp events enable, которая должна выполняться на контроллере Cisco WLC command показывает, какие беспроводные точки на нём зарегистрированы:

(Cisco Controller) >debug lwapp events enableTue Apr 11 13:38:47 2006:

Received LWAPP DISCOVERY REQUEST from AP

00:0b:85:64:a3:a0 to ff:ff:ff:ff:ff:ff on port ‘1’

Tue Apr 11 13:38:47 2006: Successful transmission of LWAPP Discovery-Response

to AP 00:0b:85:64:a3:a0 on Port 1Tue Apr 11 13:38:58 2006:

Received LWAPP JOIN REQUEST from AP

00:0b:85:64:a3:a0 to 00:0b:85:33:a8:a0 on port ‘1’

Tue Apr 11 13:38:58 2006: LWAPP Join-Request MTU path

from AP 00:0b:85:64:a3:a0 is 1500, remote debug mode is

0Tue Apr 11 13:38:58 2006: Successfully added NPU Entry for AP 00:0b:85:64:a3:a0 (index 48) Switch IP: 192.168.60.2, Switch Port: 12223, intIfNum 1,

vlanId 60 AP IP: 10.5.5.10, AP Port: 19002, next hop MAC:

00:0b:85:64:a3:a0Tue Apr 11 13:38:58 2006: Successfully

transmission of LWAPP Join-Reply to AP 00:0b:85:64:a3:a0

Tue Apr 11 13:38:58 2006: Register LWAPP event for AP

00:0b:85:64:a3:a0 slot 0Tue Apr 11 13:38:58 2006: Register

LWAPP event for AP 00:0b:85:64:a3:a0 slot 1Tue Apr 11 13:39:00

2006: Received LWAPP CONFIGURE REQUEST from AP

00:0b:85:64:a3:a0 to 00:0b:85:33:a8:a0Tue Apr 11 13:39:00 2006:

Updating IP info for AP 00:0b:85:64:a3:a0 — static 0,

10.5.5.10/255.255.255.0, gtw 192.168.60.1Tue Apr 11 13:39:00 2006:

Updating IP 10.5.5.10 ===> 10.5.5.10 for AP 00:0b:85:64:a3:a0

Tue Apr 11 13:39:00 2006: spamVerifyRegDomain RegDomain set for

slot 0 code 0 regstring -A regDfromCb -ATue Apr 11 13:39:00 2006:

spamVerifyRegDomain RegDomain set for slot 1 code 0 regstring -A

regDfromCb -ATue Apr 11 13:39:00 2006: spamEncodeDomainSecretPayload:

Send domain secret Mobility Group<6f,39,74,cd,7e,a4,81,86,ca,32,8c,06,d3,ff,ec,6d,95,10,99,dd> to AP 00:0b:85:64:a3:a0

Tue Apr 11 13:39:00 2006:

Successfully transmission of LWAPP Config-Message

to AP 00:0b:85:64:a3:a0Tue Apr 11 13:39:00 2006: Running

spamEncodeCreateVapPayload for SSID ‘SSID’Tue Apr 11 13:39:00 2006:

AP 00:0b:85:64:a3:a0 associated. Last AP failure was

due to Configuration changes, reason: operator changed 11g mode

Tue Apr 11 13:39:00 2006: Received LWAPP CHANGE_STATE_EVENT from AP

00:0b:85:64:a3:a0Tue Apr 11 13:39:00 2006: Successfully transmission of

LWAPP Change-State-Event Response to AP 00:0b:85:64:a3:a0

Tue Apr 11 13:39:00 2006: Received LWAPP Up event for

AP 00:0b:85:64:a3:a0 slot 0!Tue Apr 11 13:39:00 2006:

Received LWAPP CONFIGURE COMMAND RES from AP

00:0b:85:64:a3:a0Tue Apr 11 13:39:00 2006: Received

LWAPP CHANGE_STATE_EVENT from AP 00:0b:85:64:a3:a0

Tue Apr 11 13:39:00 2006: Successfully transmission of

LWAPP Change-State-Event Response to AP 00:0b:85:64:a3:a0

Tue Apr 11 13:39:00 2006: Received LWAPP Up event for AP

00:0b:85:64:a3:a0 slot 1!

Так же полезными могут оказаться следующие команды (выполняются на котроллере Cisco WLC):

— debug pem state enable — Настройка опций отладки для access policy manager

— debug pem events enable

— debug dhcp message enable — отображает отладочные сообщения, которые поступают от и к серверу DHCP

— debug dhcp packet enable — отображает детальную информацию пакетов DHCP, которые поступают от и к серверу DHCP

Так же вы можете использовать следующие команды debug для разрешения проблем с конфигурацией:
debug lwapp errors enable — Отображает ошибки для LWAPP
debug pm pki enable — Отображает ошибки сообщений сертификата, который используется в обмене между беспроводными точками доступа Cisco AP и контроллером Cisco WLC
Решение проблем в случаях, когда Cisco Lightweight Access Point не подключаются к Cisco Wireless LAN контроллеру

Если беспроводные точки доступа не могут зарегистрироваться на контроллере, то вам необходимо прочитать документ по следующей ссылке Troubleshoot a Lightweight Access Point Not Joining a Wireless LAN Controller.

Более подробную информацию о настройке Cisco Wireless LAN Controller и Cisco Lightweight Access Point смотрите на официальном сайте по ссылке  http://www.cisco.com/en/US/products/ps6366/products_configuration_example09186a0080665cdf.shtml